Ipv6 Delegasyon Sorunu /64 prefix vs /56 prefix

Merhabalar,

TurkNet IPv6’ya yeni geçtim ve Zyxel P-2812 üzerinde openwrt kullanmaktayım.

Network yapılandırmam şematik olarak aşağıdaki gibi:

VDSL Hattı----Zyxel P-2812 Modem----Xiaomi Mi 4a Giga Router----PC, Telefon vs.

İki cihazda da Openwrt 21.02.1 yüklü ve modem CAT6 Kablosu ile Xiaomi Routera bağlı.Evdeki diğer cihazlarda kablosuz üzerinden internete çıkıyor ve IPv4 ile ilgili bir sorunum yok, sorunsuz internete çıkabiliyorum.

Zyxel modemim türknetten IPv6 adresini otomatik alıyor ve eğer sadece modeme kablolu veya kablosuz olarak bağlanıp IPv6 testi yaparsam IPv6’yı da sorunsuz kullanabiliyorum ve modem arayüzünden IPv6 pingleyebiliyorum.Buraya kadar sorun yok.

Fakat Mi4a routera gelince işler değişiyor.Router arayüzünden IPv6 adreslerini pingleyebiliyorum fakat ne kablolu bağlantıda nede kablosuz olarak routera bağlandığımda IPv6 kullanamıyorum.IPv4 kısmında dediğim gibi sorun yok internete çıkabiliyorum.

Zyxel cihazın atadığı adresler ve yapılandırmam şu şekilde:

root@Zyxel:~# ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 44576,
        "l3_device": "pppoe-wan",
        "proto": "dhcpv6",
        "device": "pppoe-wan",
        "updated": [
                "prefixes"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a02:ff0:20f0:62e0:a86b:cb4c:**gizledim**:**gizledim**",
                        "mask": 64,
                        "preferred": 604739,
                        "valid": 2591939
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2a02:ff0:20f0:62e0::",
                        "mask": 64,
                        "preferred": 560224,
                        "valid": 2547424,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2a02:ff0:20f0:62e0::",
                                        "mask": 64
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::7aba:f9ff:feeb:a500",
                        "metric": 512,
                        "valid": 1739,
                        "source": "2a02:ff0:20f0:62e0::/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::7aba:f9ff:feeb:a500",
                        "metric": 512,
                        "valid": 1739,
                        "source": "2a02:ff0:20f0:62e0:a86b:cb4c:**gizledim**:**gizledim****/64**"
                }
        ],
        "dns-server": [
                "2a02:ff0:2:327:193:192:98:8",
                "2a02:ff0:4:327:212:154:100:18"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "001700202a020ff00002032701930192009800082a020ff0000                                                403270212015401000018"
        }
}
root@Zyxel:~#
root@Zyxel:~# ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 44754,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "2a02:ff0:20f0:62e0::",
                        "mask": 64,
                        "preferred": 560146,
                        "valid": 2547346,
                        "local-address": {
                                "address": "2a02:ff0:20f0:62e0::1",
                                "mask": 64
                        }
                },
                {
                        "address": "fd84:d69f:5292::",
                        "mask": 60,
                        "local-address": {
                                "address": "fd84:d69f:5292::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@Zyxel:~#

root@Zyxel:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd84:d69f:5292::/48'
        option packet_steering '1'

config atm-bridge 'atm'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'
        option vci '35'
        option vpi '8'

config dsl 'dsl'
        option line_mode 'vdsl'
        option ds_snr_offset '0'
        option annex 'b'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config device
        option name 'eth0.1'
        option macaddr 'c8:6c:**gizledim**:**gizledim**:**gizledim**:**gizledim**'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr 'c8:6c:**gizledim**:**gizledim**:**gizledim**:**gizledim**'

config interface 'wan'
        option proto 'pppoe'
        option password '**gizledim**'
        option username '**gizledim**@turk.net'
        option delegate '0'
        option device 'dsl0.35'
        option ip6assign '64'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '8.8.8.8'
        option ipv6 '1'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

Xiaomi yapılandırmam ve adreslerim ise şu şekil:

root@Xiaomi:~# ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 249,
        "l3_device": "wan",
        "proto": "dhcpv6",
        "device": "wan",
        "updated": [
                "addresses",
                "routes",
                "prefixes",
                "data"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a02:ff0:20f0:62e0::97b",
                        "mask": 128,
                        "preferred": 42951,
                        "valid": 42951
                },
                {
                        "address": "fd84:d69f:5292::97b",
                        "mask": 128,
                        "preferred": 42951,
                        "valid": 42951
                },
                {
                        "address": "2a02:ff0:20f0:62e0:9e9d:7eff:fe16:6aaa",
                        "mask": 64,
                        "preferred": 560025,
                        "valid": 2547225
                },
                {
                        "address": "fd84:d69f:5292:0:9e9d:7eff:fe16:6aaa",
                        "mask": 64
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "fd84:d69f:5292:4::",
                        "mask": 62,
                        "preferred": 42951,
                        "valid": 42951,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "fd84:d69f:5292:4::",
                                        "mask": 62
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2a02:ff0:20f0:62e0::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 2547225,
                        "source": "::/0"
                },
                {
                        "target": "fd84:d69f:5292::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "source": "::/0"
                },
                {
                        "target": "fd84:d69f:5292::",
                        "mask": 48,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "fd84:d69f:5292:4::/62"
                },
                {
                        "target": "fd84:d69f:5292::",
                        "mask": 48,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "2a02:ff0:20f0:62e0:9e9d:7eff:fe16:6aaa/64"
                },
                {
                        "target": "fd84:d69f:5292::",
                        "mask": 48,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "fd84:d69f:5292:0:9e9d:7eff:fe16:6aaa/64"
                },
                {
                        "target": "fd84:d69f:5292::",
                        "mask": 48,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "2a02:ff0:20f0:62e0::97b/128"
                },
                {
                        "target": "fd84:d69f:5292::",
                        "mask": 48,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "fd84:d69f:5292::97b/128"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "fd84:d69f:5292:4::/62"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "2a02:ff0:20f0:62e0:9e9d:7eff:fe16:6aaa/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "fd84:d69f:5292:0:9e9d:7eff:fe16:6aaa/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "2a02:ff0:20f0:62e0::97b/128"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::ca6c:87ff:fe80:ecf8",
                        "metric": 512,
                        "valid": 1551,
                        "source": "fd84:d69f:5292::97b/128"
                }
        ],
        "dns-server": [
                "fd84:d69f:5292::1"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "00170010fd84d69f529200000000000000000001"
        }
}
root@Xiaomi:~# ifstatus lan
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 269,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.2.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "fd84:d69f:5292:4::",
                        "mask": 62,
                        "preferred": 42939,
                        "valid": 42939,
                        "local-address": {
                                "address": "fd84:d69f:5292:4::1",
                                "mask": 62
                        }
                },
                {
                        "address": "fdc5:4db9:bd0f::",
                        "mask": 60,
                        "local-address": {
                                "address": "fdc5:4db9:bd0f::1",
                                "mask": 60
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@Xiaomi:~# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdc5:4db9:bd0f::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

root@Xiaomi:~#

Yabancı bir forumdan edindiğim bilgiye göre servis sağlayıcı /64 prefix yerine /56 prefix verirse Xiaomi routerda da IPv6 kullanabileceğim.Kısacası ağı genişletmem gerekiyor.

TurkNet /56 prefix sağlıyor mu?Bilgisi olan veya kullanan var mıdır?

xiaominin wan portunu kapatın wireless gateway olarak çalışsın?

Hocam cevap için sağol.

Maalesef bahsettiğin şekilde çalışmıyor denedim. 64 prefix sadece tek subneti desteklediği için.

Bu linkteki en alttaki tabloya göre 56 prefix almam gerekiyor:

Aklıma PPPoE üzerinden bağlanmak(Zyxeli sadece dsl işleri için kullanacağım xiaomi yi geri kalan işler için) geliyor ama onunda olacağına pek emin değilim ama deneyeceğim.

Yapılandırmalarla ilgili çok fazla bilgim yok. Normalde modemi router modunda wan portundan bağlayınca ip dağıtmaya başlıyor, ama lan portundan bağlantı yapılırsa ip dağıtım işini sadece ana modem yapıyor.

Her ne kadar v6’da çok bir tecrübem olmasa da v4’deki bilgim ile yardımcı olmaya çalışacağım. Ayrıca topolojiyi netleştirince deneme imkanım var sayılır, yardımcı olabilirim.
Öncelikle zyxel’in lan4 portunu openwrt wan5 olarak isimlendirmiş ve oradan Xiaomi’ye çıkılmış olarak anladım. Bir kere mesele prefix meselesi değil çünkü yanlış konfig var gibi. İki router ile network kullanmanın birkaç yolu var bunlar:
1: Zyxel’in wan çıkışı yaparken Xiaomi’nin LAN’da kalması. Böylece xiaomi wlan interface’i ile lan interface’i bridge olduğu için statik routesız iletir.
2: Eğer v4 için konuşacaksak, Zyxel yine WAN kurmuşken xiaomi’nin farklı bir /24 subnette ki siz de 192.168.2.0 ile onu yapmışsınız, 1.0/24 zyxel’e route etmesi. bunun için yine xiaomi’nin zyxel’e lan porttan bağlanması gerekir ancak ayrıca default gateway olarak 1.1/24 zyxel işaret edilmelidir xiaomi menüsünden.
3: Eğer zyxel bridge modda ise o zaman Xiaomi’ye wan girerek istediğinizi yaparsınız.

sonuç olarak çizim ile arayüz -adres ilişkisini gösterirseniz daha faydalı olur.

1 Beğeni

Hocam yeniden cevap ve ilgilendiğin için sağolasın.

Şematik olarak aşağıdaki resimde anlatmaya çalıştım ve arayüz fotoğraflarını ekliyorum:

Özetle zyxel lan portu xiaominin wan portuna takılı.

  1. maddedeki dediğiniz gibi hiç kullanmadım o yüzden yorum yapamayacağım.

  2. maddedeki yazdığınız kısım IPv4 için tamamen doğru.Zaten eskiden bu şekilde kullanıyordum IPv4 olarak.Default gatewayde Zyxel’in ip si olan 192.168.1.1 gösterilmiş durumda.Manuel olarak da ayarlayabiliyorum bunu ama DHCP olduğu için otomatik olarak alıyor zaten.Bu kısma kadar yanlış bir config olduğunu düşünmüyorum.

Modeme lan kablosu ile pc yi bağladığımda IPv6 da sorun yok, sıkıntısız çalışıyor.Ama router a kablolu veya kablosuz bağlandığımda IPv6 test ettiğimde sadece IPv4 olarak algılıyor.

Modem arayüzünden ve router arayüzlerinden IPv6 ping ettiğimde ise ikisinde de sorun yok.

  1. Maddede anlattığınızı yapmak için zyxeli bridge mode a alıp xiaomi wan kısmını PPPoE olarak ayarlamam gerekiyor anladığım kadarıyla doğru mudur?

Anlatamadığım birşey olursa daha fazla detay-şema-resim ekeleyebilirim.

Cevaplar için şimdiden teşekkürler.

Hocam sorununuzun benzerini keenetic + openwrt ile yaşamıştım. Sorunu interface üzerinden wan ve wan6 portlarındaki dhcp>ipv6 settings kısmındaki RA ve NDP Proxy yetkilendirmeleri ile çözmüştüm. Tam kombinasyonu hatırlamıyorum ama mi Routerda master interface olarak wan’ı ayarlayıp wan6’da ra ve NDP için relay dhcp için Server mod vermeniz gerekiyor diye hatırlıyorum.

Benzer bir konuyu ekliyorum.

Evet 3. Madde için doğru anlamışsınız.
Konuyu ilk görünce siz iki router için de wan bağlantısı kurmak istiyorsunuz diye anlamıştım bir yandan. Çünkü her ne kadar openwrt xiaominin normalde wan olan fiziksel portunu lan olarak tanımlama yeteneğine sahiptir sahip olsa da, ek olarak belirtilmediği için o ihtimali atladım ve yukarıdaki önerileri verdim.
Xiaominin v6 lan arayüz config sayfasında default gateway ayarı olması gerek aslında tıpkı v4ün fotosunu gösterdiğiniz gibi. Eğer landa o ayar yoksa wan arayüzünü otomatik değil statik yapılandırın. O esnada başka bir mesajda anlatıldığı gibi röle imkanı veren opsiyon çıkacaktır diye tahmin ediyorum. V6 ile peki tecrübem yok o yüzden şimdi meraktan zyxel + Asus ikilisi ile benzer bir yapı kurup bakacağım

@volkan hocam sonuna kadar haklısın ama henüz IPv6 çok yaygın olmadığı için ISP’lerden senin benim gibi /56 prefix talep eden olduğunu çok sanmıyorum.Talep olmayınca yapmadıklarını düşünüyorum.Kaldı ki maliyet getirecek bir operasyonda değil.

@hahamyan hocam bende verdiğin linkten değil ama openwrt dokümantasyonundan buldum IPv6 Relay işini.

Zaten NAT6 Mask sayfasında da belirtmiş.

" Being provided a smaller prefix than a /64 or worse, none at all or a ULA address

Note: If you are provided a /64 prefix, you may not need to use NAT6 and instead should try relay mode."

Sonuç olarak Xiaomide /etc/config/dhcp dosyasına aşağıdaki satırları ekledim ve server yazan satırları sildim.Geri kalan tüm yapılandırma openwrt fabrika ayarları, başka ayar değiştirmedim.

config dhcp lan
    option dhcpv6 relay
    option ra relay
    option ndp relay
    ...
 
config dhcp wan6
    option dhcpv6 relay
    option ra relay
    option ndp relay
    option master 1
    option interface wan6

Sonuç olarak Xiaomi Zyxel IPv6’sını relaylemeye başladı ve artık zyxel ve xiaomi üzerinden IPv6 sorunsuz çalışıyor.Kısacası amacıma ulaşmış oldum :slightly_smiling_face:

@frknl “Eğer landa o ayar yoksa wan arayüzünü otomatik değil statik yapılandırın.” bunu da denemiştim hocam IPv4 gibi ama becerememiştim.Belkide ben yapamadım ama yukarıda anlattığım gibi sorunsuz çalışıyor.

Benimle aynı sorunu yaşayan ve yaşayacak olan diğer arkadaşlara yardımcı olmak için aşağıda yapılandırmanın görselini de bırakıyorum:

2 Beğeni

Zyxel in vmg 3625 modemi içinde ipv6 için bir çözümü olan birini bulabilsem.:pensive:

çözdüğünze sevindim. ben de asus ile denedim bir şeyler ama olmadı kesinlikle. Asus kendisi için link local adres üretiyor onu kullanarak bir statik wan açmaya çalıştım ama olmadı.

Faydalı olduğuna sevindim hocam keyifli kullanımlar dilerim :slight_smile:

relay özelliği çoğu profesyonel cihazda bile yok. linux tabanlı openwrt gibi platformlarda var.

keşke /64 yerine /56 verilse ve problem kökten çözülseydi

1 Beğeni

TurkNet 'te ipv6’nın düzgün çalışmamasının sebebi bu olay sanırım.

Tek bir ipv6 adresi geliyor ama router bunu paylaştıramıyor.
Mesela bir cihazda ipv6 testi yapıyorum testi geçiyor, diğer cihaz ise geçemiyor.

Tuhaf bir sorun var. /56 prefix niye verilmiyor anlamadım.

vmg3625’de nat6 veya relay özelliği yok modem zaten dandik, o yüzden bu /64 prefix ile ipv6 çalışmıyor.

Since every IPv6 host uses /64 by design, every host subnet uses that prefix, making it most common one.

Home networks usually get assigned a /60 (16 subnets), or may get /56 (256 subnets)

Larger enterprises will typically get a /48 (65,536 subnets, or 256 /56 subnets).

" the possible options when choosing a prefix size to delegate are /48, /52, /56, /60 and /64. However, /64 is not sustainable, it doesn’t allow customer subnetting, and it doesn’t follow IETF recommendations of “at least” multiple /64s per customer. Moreover, future work within the IETF and recommendations from RFC 7934 (section 6) allow the assignment of a /64 to a single interface (draft-ietf-v6ops-unique-ipv6-prefix-per-host-07).

The following sections explain why /48 and /56 are the recommended prefix assignment sizes for end customers."

It is strongly discouraged to assign prefixes longer than /56 unless there are very strong and unsolvable technical reasons for doing this.

There are enough IPv6 addresses to delegate end-users a /48, so a /56 already represents a sizeable restriction. There is no need to delegate fewer addresses than that, so if your IPv6 allocation is insufficient to provide a /56 to each end customer (remember there are 134 million /56s in a /29 and 16,7 million in a /32), explain to your RIR that your initial allocation was too small and that you require a larger allocation based on your IPv6 implementation plan. Offering less than a /56 can be feasible if just a /29 is allocated and 6RD is being used, as an IPv4 address is embedded in the IPv6 prefix. However, even in this case, a larger allocation from your RIR can be justified and the transition protocol allows other ways to sort it out.

Assigning a /64 or longer prefix does not conform to IPv6 standards and will break functionality in customer LANs . With a single /64, the end customer CPE will have just one possible network on the LAN side and it will not be possible to subnet, assign VLANs, alternative SSIDs, or have several chained routers in the same customer network, etc.

1 Beğeni
1 Beğeni

Merhaba,

Ararken bu konuyu buldum ve yazayım dedim.

Benim modem testleri vs geçiyor ipv4 ve ipv6 aynı anda alıyor. Ve LAN’da ki ipv6 özelliği olan tüm cihazlar ipv6 alıyor dışarıdan sorguda da görünüyor bunlar. Buraya kadar sıkıntı yok.

Ancak dışarıdan içerideki QNAP, File Server vs ipv6 adresi ile port açık olmasına rağmen erişilmiyor. İpv4 ile zaten sorun yok çünkü statik ip kullanıyorum.

Bu sorun sizce /64 prefixten mi kaynaklanıyor ?

En son detaylı bir yazı ile ticket açtım 3-4 saat sonra “isterseniz ipv6 yı iptal edelim, ipv4 ile devam edin” gibi harika bir öneri ile aradılar :joy::joy:

Ne yapacağımı bilemedim :blush:

Konuyu açan arkadaş gibi ikinci router kullanmıyorsanız /64 ile tüm cihazlarınız NAT olmadan internete çıkar. ipv6 adresi almasına rağmen ipv6 bağlantısı kuramayanların çoğunun yaşadığı sorunun sebebinin modemin wan bacağına lan prefixinden ip verilmesi olduğunu düşünüyorum.

@btekcan karşı tarafta da ipv6 bağlantısını test ettiniz mi?

1 Beğeni

İnternete çıkmada zaten sorun yok. Hatta ipv4 ü kapatırsam sadece ipv6 olanlara giriliyor. Sorun dışarıdan içeriye gelmiyor. Yani içerideki her hangi bir cihaza erişilmiyor

ipv6 adresine erişebilmek için yine bir ipv6 adresi gerekiyor. (dışarıdan erişmeye çalışıyorsunuz ya o dışardaki pc de ipv6 ya sahip olmalı.)

modem firewall’ını ve windows firewallı kapatıp deneyin. (sonra açın tabi.)

ipv6 adresini köşeli paranteze alın. [2002:2:2:2:1:1:1:1]:443 gibi

1 Beğeni