DNS çalışmıyor

İyi forumlar, Ağustos başından beri siteler yavaş yükleniyordu, arkadaşım ziyarete gelince yavaşlığı hissetti ve galiba DNS problemi ile karşı karşıyayım. Siteler ve uygulamaların açılması 2-8 sn buluyor veya komple açılmıyor, 2 kere deniyoruz düzeliyor. Problem OS ve cihaz fark etmeksizin tüm ağda mevcut. DNS adreslerini değiştirdim fark etmedi, modeme reset falanda attık nafile. VPN ile problem yaşanmıyor orası ayrı.

Denediğim yöntemler arasında:

  • DNS adreslerimi değiştirdim (1.1.1.1, 8.8.8.8, 9.9.9.9 veya düz TurkNet)
  • Modemi tekrardan kurdum/reset attım
  • Aile profili açık değil, kontrol ettim, değiştirdim tekrar sıfırladım ve SMS geldi.
  • VDSL ayarlarıyla oynadım, SNR arttır/azalt vs.
  • Başka cihazlar ile test yaptık, durum aynı
  • VPN ile bağlantı kurunca problem olmuyor(?)

Örn:

Ağ değerleri ve hız testleri iyi fakat bir sayfayı açılması için 2-3 kere yüklemem gerekebiliyor. Arıza kaydına DNS bozuk yazmak çok absürt geldiği için önce buraya danışmak istedim. Problem ciddi şekilde sinir bozucu, GitHub veya Docker Hub’da timeout almaktan sinir krizi geçirmek üzereyim. Steam ve Apple Music içinde geçerli…

Bilgiler yetersiz gelir ise, öğleden sonra elimden geldiğince problemle ilgili ekran görüntüsü atmaya çalışırım.

Şimdiden teşekkürler.

Statik IP’niz varsa düzelene kadar IP blok değişikliği talebinde bulunun.

Merhaba @fatihemre22 arıza kaydı açın açtığınız arıza kaydına sayfalar yavaş yükleniyor sürekli dns adreslerine yaptığım tracert ve ping testlerinden zaman aşımı hatası alıyorum şeklinde yazın tracert ve ping testlerini kablolu bağlantı ile yaparak ekran görüntüsünü kayda ekleyin temsilci network ekibine iletsin bir kontrol etsinler.
Ek olarak farklı dnslerde de aynı sorunu yaratıyor mu?

1 Beğeni

Statik ip kullanmıyorum. 2 haftam kaldı burada, ondada github, dockerhub vs erişim lazım oldu kanser olduk yoksa ben bu konuyu açmazdım seneye bırakıcaktım.

DNS adreslerimi değiştirdim fark etmedi. Kablolu test istemiştiniz, önceki ve sonraki herşey kablolu:
github

VDSL Hat değerleri:



VPN açtığımda problem olmuyor.

VPN dig


Gerekli fotoğrafları destek kaydı açıp ekledim, VPN le problem olmadığını belirttim fakat fotoğraf eklemedim, siteyi açamadım malum.

Geçmiş olsun. Büyük ihtimal bağlı olduğunuz cihaz yüksek işlemci veya bellek sorunu yüzünden UDP paketleri düşürüyor. Bu durumu VDSL’de yaşayanlar oluyordu. Sorun tam olarak nerede bilmiyorum ancak VDSL olunca oluyor TurkNet 'te. Sizinle alakası olmadığını rahatça söyleyebilirim. Cloudflare’in DNS over TLS veya HTTPS DNS çözümleri var. PC WARP kurarak Android’de ise ayarlar menüsünde özel DNS ismindeki ayar ile açılıyor. BElki onu açınca drop yemezsiniz.

Cevabınız için teşekkürler.

Bozulmuşta olabilir, bulunduğum yerde sezon kapandı sayılır ki VDSL verilerimde bir yükseliş fark ettim.

Adguard Home üzerinden Cloudflare ve AdGuard DoH kullanıyordum, şimdilik TTL ve cacheyi arttırdım. DNS over TLS e bir bakayım. Bu mesajım kafa karıştırmasın, üstteki resimlerde/konuda Adguard Home kapalı/kullanılmadı.

12 gün daha köydeyim zaten, network üzerinden çözülebilecek birşey olabilir diye arıza kaydı açtım yoksa seneye bırakacaktım. Arkadaşım şikayet edince bi Query sayısına bakayım demiştim.
okay

WARP’tan haberim vardı, açılmayan NordVPN sitesine login için kullanıyordum (Türksat Kablo’ya selamlar olsun) :joy:
Profili direkt modemden çalıştırdığım bir VPN aboneliğim zaten mevcut onu kullanıyorum. Tek tek evdeki her cihaza WARP kurup anneme nasıl açacağını anlatmak zor geldi şahsen. %6-7 hız kaybı ideal. Umarım böyle kullanmak zorunda kalmam…

WARP’da dahil olmak üzere VPN’ler ile problem yaşanmıyor. Modem ile alakalı olma ihtimali var mı acaba? Durduk yerede birden bozulacak değil diye düşünüyorum malum UPS falan bağlı… Kafamda deli sorular…

1 Beğeni

Peki alternatif olarak kendi makinenize bir DNS sunucu kurmayı denediniz mi?

Bu küçük portable DNS sunucuyu test edebilirsiniz: MaraDNS

Elbette her cihaza WARP kurmak mantıklı değil ancak denediğiniz gibi bu sorunu çözmüş. Tahmin ettiğim gibi, sıkıntı modeminizle ilgili değil. TurkNet VDSL’de ya tümden UDP düşürüyor ya da DNS portunda buna sebep olacak bir şey yaşanıyor. Öyle veya böyle bu durumu bir tek siz yaşamadınız ve DNS paketleri düşüyor. Bunu ping falan atarak da kanıtlamak zor. Wireshark + nslookup açarak ekran görüntüsü veya pcap dosyasını TurkNet 'e göndermeye çalışın. Bu arada dediğimi de ekleyebilirsiniz. VDSL’de bu epeydir var.

Ek olarak statik ip dahi alsanız 53 no’lu portu dışarı açamıyorsunuz. İlginç bir şekilde TurkNet bunu kendine ayırmış veya ticari maksatla kullanılmaması için filtrelemiş.

1 Beğeni

Ağda Adguard Home (AGH) mevcut, cachesi var ki bu test etmek için unbound veya maradns kurmak istemiyorum ki problemi çözmek yerine ertelemiş olacağız. AGH bile upstream dns sunucuları çözmekte zorlanıyor. Problem seçtiğim DNS sunucuları falan değil, AGH kullanmasam bile çalışmıyor :smiley:

Ayrıca, ne yapacağım ki? Min TTL süresini 1 saate mi çekeceğim? 4 GB cache mi kurayım?? Bu böyle gider durur…

Benden istemedekleri sürece Wireshark kaydı atmak istemiyorum yoksa durduk yere bakacaklarını düşünmüyorum. Desteğe çok bilmişlik taslayınca pek yardımı dokunmuyor ki daha önce yaşadım, anlamıyor numarası yapmak daha etkili…

Başkasına hizmet açmayacaksanız, DNS adresini dışarı açmak pek iyi değil. DNS amplification attack ta kullanılma ihtimaliniz var. Kendi ağınıza VPN ile bağlanmak daha iyi bir çözüm, normalde ben öyle yapıyorum.

Desktek kaydı:

Kablolu olarak ilettiğiniz sonuçlarda genel olarak modemden çıkarken bir kayıp olduğu gözüküyor. Farklı LAN portu ve ethernet kablosu ile deneme yapma şansınız varsa yapmanızı mümkünse farklı modem ile de kontrol sağlamanızı rica ederim. Modem kaynaklı bir sorun söz konusu olabilir.
İyi günler dileriz.

İletilen bilgiler doğrultusunda çıktı göndermenizi rica ederim.
İyi günler dileriz.

Geri dönüş falan oldu ama şahsen buradan ayrılmama 3-4 gün kaldı ki ben uğraşamaycağım. Seneye bakacağız artık, başka modem getirip test ederim ve problem devam ediyorsa ben artık başka yöntemler veya ISP denerim. Türk Telekom kullanan arkadaşımda problem yoktu. İlginiz için teşekkürler.

Duruma göre belki seneye geri dönüş yaparım konuya.

Merhaba statik ip ile 53 portu açık görünüyor. Ben port test yaptığımda güvenlik duvarıma ulaştığını görebiliyorum.

Daha önce başıma geldi güvenlik duvarından önlemek lazım.

Malesef bende kapalı, bir ticket açmam gerekiyor sanırım. DnsSec kullanıyorum ben ataklar ile başa çıkmak için, 95% kadarını bertaraf ediyor zaten.

53 numaralı portumun açılması için ticket oluşturdum, bu konu hakkında yardımcı olabilir misiniz @alperenatici ?

Ticket No: 56038433